和弦轨,rea牌!

Chord Tool
1231313

Chord Tools.lua (51.7 KB)

大的框架基本上不会改了,有什么想法请留言。
最新版本增加了和弦类型,新增了右键试听功能。
再次新增了和弦级数,自动设置录音监听和MIDI IN。

4 Likes

挺好的呀,会放 reapack 源吗

会的,不过我不会操作,都是一刀帮我弄的。 :grinning:

嗯,已上传ReaPack。

错误
运行出现错误,有遇到这样情况吗?

显卡驱动太老了,你是什么操作系统?

哦哦,win7,七八年的电脑了

看看显卡设置里面能不能打开 OpenGL 3.2这个选项,有些显卡默认关闭了,我的笔记本就是这样设置好的。

强大且实用的脚本,以下几点不知是否可优化

1、目前每次创建和弦轨都会创建新和弦轨道

有没有可能转换和弦轨时只锁定一轨

2、创建文本和弦、轨道和弦、区域和弦时,必须先建立文本和弦

有没有可能让3者独立工作:

2-1 点击创建文本和弦时,创建文本和弦。如果之前创建过文本和弦则先删除再创建;

2-2 跳过创建文本和弦,直接点击创建和弦轨时,自动创建文本和弦(是否必须)同时创建和弦轨。如果之前有创建过文本和弦或和弦轨,则先删除文本信息或和弦轨;

2-3 跳过创建文本和弦,直接点击创建区域和弦时,自动创建文本和弦(是否必须)同时创建区域和弦。如果之前有创建过文本和弦或区域和弦,则先删除文本信息或区域信息。

3、增加一键清空所有(一键移除文本和弦、和弦轨、区域和弦)按钮

当前的设定是在建立lyrics以前会清除之前的所有歌词,区域标记也会被全部清除。
直接建立和弦轨也可以,但是考虑到有可能需要手动输入一些特殊的和弦符号,所以分开了。
至于和弦轨的删除判断这个还是留给用户比较好,因为万一误操作会删除其他有用的轨道。

问题已解决,谢谢大神

这脚本确实不错,可惜我的集成显卡只支持OpenGL3.0,一直提示错误。脚本无法运行。能不能让其他显卡也兼容。

imgui 库需要至少openGL 3.2,没法。

升级到2021.11.17驱动可以使用了,谢谢

感谢分享,真不错的脚本

Chord Tools.lua:552: attempt to call a nil value (field ‘ImGui_CreateContext’)请问这个是什么意思呀?我在midi编辑窗中选中音符,然后运行脚本弹出来的。第一次用这个脚本,暂时不会使用 :sneezing_face:

需要安装 IMGUI的库,放到 UserPlugins文件夹里面,重启软件。
reaper_imgui-x64.dll (1.8 MB)

抱歉我是mac,可以传个mac的包吗?感谢!

我没有mac,你用reapack安装扩展包吧。